Opened 5 years ago

Closed 20 months ago

Last modified 20 months ago

#255 closed defect (fixed)

More Tag custom text disappearing

Reported by: mikebuffington Owned by:
Priority: minor Milestone: Next Release
Component: Publishing Version: 2.9
Keywords: Cc:

Description

When I make a post on wordpress (2.8.4 running on my server) via the web and use the custom more tag like this:

<!--more Custom Text-->

It fails to show up in the iPhone version. It only shows:

<!--more-->

when I look at posts on the iPhone. If I update the post via the iPhone, the custom text disappears from the website. Just looking at the post on the iPhone does not affect the blog post.

Change History (16)

comment:1 Changed 5 years ago by iammattthomas

  • Resolution set to fixed
  • Status changed from new to closed

I've confirmed this is fixed as of r609.

comment:2 Changed 5 years ago by iammattthomas

  • Milestone set to 1.4
  • Resolution fixed deleted
  • Status changed from closed to reopened

Jumped the gun here. While adding a new custom more tag works from the app, it disappears when you re-open the post (or open any post that includes a custom more tag).

comment:3 Changed 5 years ago by iammattthomas

  • Version set to 1.4 beta

comment:4 Changed 5 years ago by iammattthomas

  • Version changed from 1.4 beta to 1.3

comment:5 Changed 5 years ago by iammattthomas

  • Owner set to Sunil
  • Status changed from reopened to assigned

This is a pre-existing issue in version 1.3.

I can type a custom tag, like:

<!--more Continue Reading-->

and when I save, the post on the web correctly uses "Continue Reading" as a link to the rest of the article. However, when I re-open the post for editing within the iPhone app, it shows me only this:

<!--more-->

If I make other changes and save the article, the "Continue Reading" is indeed stripped out and I'm left with a more tag with no custom title.

I'll assign this to Sunil since it's an issue unrelated to the changes in 1.4.

comment:6 Changed 5 years ago by janakirampalepu

While saving the post, in the request along with all the values we send the description along with <more> tag with Custom text (if any) to server.

But in the response from server, the description doesn't contain any tag named <more> . By analyzing its observed that the description content is divided into two keys "description" and "mt_text_more" (if there was a more tag in the request),

In the Response The "description" key contains all the values that appeared before <more> and the "mt_text_more" contains the rest values of the description after the <more> tag .

The <!--more Continue Reading--> is missing in the Response from server itself.

comment:7 Changed 5 years ago by josephscott

I think that's correct, WP doesn't provide the custom more text back to clients when requesting post information. I've created a WP ticket about this - http://core.trac.wordpress.org/ticket/10933

comment:8 Changed 5 years ago by iammattthomas

  • Milestone changed from 1.4 to 1.5

Thanks Joseph. We'll take another look at this in the next milestone.

comment:9 Changed 5 years ago by iammattthomas

  • Milestone changed from Next Release to Future Release

The related ticket in core has been punted to a future release, so we'll have to do so too for the time being.

comment:10 Changed 4 years ago by iammattthomas

  • Owner Sunil deleted

comment:11 Changed 4 years ago by frsh

  • Milestone changed from Future Release to Next Release
  • Version changed from 1.3 to 2.7

comment:12 Changed 4 years ago by frsh

  • Milestone changed from Next Release to 2.7

comment:13 Changed 4 years ago by frsh

  • Milestone changed from 2.7 to 2.9
  • Version changed from 2.7 to 2.9

comment:14 Changed 3 years ago by koke

  • Milestone changed from 2.9 to Future Release

comment:15 Changed 20 months ago by aerych

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [3735]) Fixes #255. Make sure we keep custom more text.

comment:16 Changed 20 months ago by aerych

  • Milestone changed from Future Release to Next Release

Correcting milestone

Note: See TracTickets for help on using tickets.